System requirements

Windows 7 or above

Internet Explorer 9 or above

Stable Internet Connection

Headphone and Microphone

The Password suite of tests requires a Microsoft Windows operating system. They cannot be run on MacOS, Linux or smartphone operating systems.

Windows must be activated and up to date. Although Internet Explorer 9 is the minimum required, we recommend Internet Explorer 11 be used as this is Microsoft’s currently supported version.

Share on twitter
Twitter
Share on linkedin
LinkedIn